LTE + Pybytes?

Gabriel Ballesteros shared this question 2 years ago
Need Answer

Hi,


I have been working on a couple of Gpy boards and got to a position where everything is functional. Now I want to have a nice dashboard, add FOTA, etc.


LTE is working. I've been doing HTTP requests without any issues. But no support on Pybytes? Why?


The configuration menu on Pybytes's admin panel does ask what priority of network modules I want when I add a new device. I select LTE as the only option, all good. No configuration fields for the LTE network to be seen though. And of course, the board fails miserably when it tries to connect to PyBytes. The terminal shows:

Using configuration from /flash/pybytes_config.json
WMAC: 30ae********
Firmware: 1.17.5.b4
Can't enstablish a connection with the networks specified
There is no LTE field that can be set in pybytes_config.json, so I went a bit further and downloaded the library. Surprise, no LTE functions. Only LoRa, WiFi and Sigfox.


Am I missing something? Is this a feature that is going to be added?


Thanks

Comments (3)

photo
1

What is the timing on adding LTE?...assuming LTE will be added. Wanted to use gpy units with pybytes.

photo
1

yes:)

photo
1

HAS THE lte SUPPORT for Pybytes being added?

photo
1

Hi Tanmay,

yes. We will roll out sigfox for uplink messages this week. (downlink is comming soon too).


We start working on LTE soon, it's on our road map. Thanks for the patience.

photo
photo
1

Hi, LTE support will be added to Pybytes in upcoming weeks.

photo
1

Ok, so if I do development right now with WiFi I should be able to move over to LTE without any issue?